Bernard

À propos…

Pseudo
Bernard
Inscrit
Visites
261
Dernière connexion
Statuts
Member

Réponses

  • Bonjour, A partir de la base de la collègue onglet >administration>sauvegarde , créer une sauvegarde des tables du portail Faire une sauvegarde de la base avant toute bidouille sauvegarde>groupe de table>créer un groupe "CMS", cocher to…
    dans Restaurer Portail Zen Commentaire de Bernard 19 mai
  • Bonjour, As-tu lancé les opérations de réindexation de la base après le passage à la 5.07 ?A tenter.
  • Bonjour, Le message d'erreur s'affiche après avoir lancé la demande d'installation ? ( http://localhost/pmb/tables/install.php)Si le dossier pmb est bien dans /htdocs/ c'est curieux. Tu as vérifié la compatibilité du php avec  la version de pmb ?  …
  • Bonjour, Dans le paramètres "mail_method" , section opac, j'ai cette valeur : smtp,localhost:25,0
    dans mailing Commentaire de Bernard novembre 2020
  • Bonjour, J'ai refait le tour des paramètres et il y avait un souci avec l'url du portail. J'ai activé le certificat https il y a peu de temps et je n'avais pas mis à jour l'url en https dans :   >paramètres > portail > url_base_cms_build C…
  • Bonjour, J'ai abandonné le Google drive pour mettre à disposition des images, ce n'est pas adapté.Reste la solution de créer un dossier à la racine chez l'hébergeur et d'y loger les fichiers. On peut alors récupérer l'adresse des images et l'intégr…
  • Bonjour, Après tâtonnements et tests, je suis parvenu à obtenir l'import des lecteurs avec mot de passe (et ça fonctionne dans le portail). Pour une raison que je ne m'explique pas, si on fait l'import des lecteurs dans PMB en demandant MAJ complè…
  • Bonjour, Remise à jour de ce sujet. Je constate, comme Romaric, que lors de l'import des lecteurs le mot de passe (présent dans le csv) n'est pas importé, tous les autres champs sont ok. Vérification via phpmyadmin des tables : - le champ empr_…
  • J'ai refait une installation locale (pmb normandie) . Ajouté les catégories et codestat en admin. Puis modifié le script comme le propose Anne Marie (solution 1). Ca ne fonctionne pas.J'ai ensuite modifié les valeurs dans les tables empr_codestat et…
    dans Import lecteurs Commentaire de Bernard août 2020
  • J'avance un peu sur mon problème. J'ai survolé trop vite l'excellente littérature d'Anne Marie Cubat. Mon souci de fiches emprunteurs vide est bien repéré dans son document "PMB - Import de lecteurs - Généralité". Je fais mes tests en local à pa…
    dans Import lecteurs Commentaire de Bernard août 2020
  • Bonjour,  La visite du site d'Anne-Marie Cubat me semble incontournable. La lecture des fiches produites par l'Académie de Bretagne pourra compléter, voir Citédoc. Bonne journée
  • Jamais trop tard effectivement. De fait , avec un utilisateur au moins : ça passe. Merci Cédric
  • Bonjour,  J'utilise la version 5.0.7 et je constate le même message d'erreur lorsque je réindexe la base, ou un panier, ou quand je fait une importation de notice :  Warning: call_user_func_array() expects parameter 1 to be a valid callback, class …
  • Effectivement, Yaz est activé et fonctionne chez Infomaniak. Hébergement annuel à 70€.
  • J'ai refait l'installation en ligne. Cette fois j'ai dézippé pmb et transféré tous les fichiers via ftp. J'ai relancé l'installation et cette fois le style fonctionne. Conclusion : éviter de déziper sur le serveur ? C'est curieux mais bon...
  • Bonjour, Pas de réponse à ta question mais je rencontre le même problème. Je viens d'installer pmb7rc. J'accède bien aux menus mais il n'y a aucun style. Les liens sont opérationnels. Les styles appelés par la page (common et enjoy) sont bien prés…
  • Bonjour,  J'ai refait une installation complète et cette erreur a disparu. Pas d'explication.  Merci
  • Oh mais c'est un paramètre que je n'avais pas encore testé. Effectivement, j'obtiens comme ça l'affichage hiérarchique. Je suis bien d'accord sur le côté indigeste de l'affichage mais comme j'ai un souci avec mes champs personnalisables je tente de …
  • Problème résolu : c'était effectivement la procédure de Citedoc qui ne fonctionnait pas.  Je leur ai signalé et ils ont fait la correction aussitôt. 
  • Bonjour Anne-Marie,  Merci pour cette piste. Je viens de tester et effectivement j'obtiens une navigation structurée. Je pense que je vais l'adopter. Mais mon questionnement concernait l'affichage hiérarchisé au niveau de la notice, exemple :  https…
  • Je viens de tester la procédure Citedoc d'ajout d'un genre (N1.1) dans une version 4.2.9 de pmb et ça fonctionne. Curieux...
  • Bonjour Anne-Marie,  C'est juste ce qui me manquait, merci pour ces requêtes.  Je n'avais pas d'illusions sur un traitement totalement automatique, les miracles se font rares. Je vais donc tâcher de m'organiser pour faire cette bascule patiemment en…
  • Bonjour,  Je me permets de relancer ce fil de discussion.  Existe-t-il un moyen pour basculer le contenu de champs personnalisables vers des catégories d'un thésaurus ? Objectif : comme l'explique Anne Marie, la gestion via les catégories d'un thé…
  • Ok. Voici un mail : cdi@st-ambroise.org Si tu peux me faire une copie/écran c'est excellent. Merci d'avance
  • Merci de tes précisions. J'ai suivi les indications de la FAQ mais je n'ai pas les infos pour compléter le formulaire d'ouverture d'un port chez infomaniak. Tu pourrais me dire quelles valeurs infomaniak a renseigné chez toi pour permettre le z3950…
  • Bonjour,  Même constat pour moi. PMB 5.5, installé chez Infomaniak, Yaz ok. Mais, message d'erreur lorsque je tente d'utiliser la z3950 :  BNF : Echec lors de la recherche : Connect failed, z3950.bnf.fr:2211/TOUT_UTF8Citedoc : Echec lors de la rec…
  • Bonjour Anne-Marie,  Merci pour ces précisions. Après réflexion, je pense qu'effectivement j'aimerais suivre ta proposition d'utiliser le thesaurus général ou un spécifique pour gérer ce que permettaient les champs personnalisables. Ta proposition d…
  • Bonjour,  Non pas d'éditeur installé dans la 4.2. Non plus dans la version 5. Du coup j'ai copié/collé le code depuis une version en local . Ca fonctionne mais c'est curieux d'avoir ainsi perdu des contenus d'infopage. 
  • Merci pour vos réponses. J'ai finalement contourné le problème : puisque l'installation fonctionnait bien en local -> passage de la base de 4.2 vers 5.5 de pmb, j'ai sauvé la base locale et je l'ai installée en ligne. Ca semble fonctionner.
  • Le problème apparait lors de la restauration de la base chez l'hébergeur. Précision : la sauvegarde est celle d'une base pmb 4.2.9, je l'installe sur un pmb 5.0.5, normalement l'upgrade de la base devrait se faire sans problème me semble-t-il. Curie…