nouvelle bibliotheque

Bonjour a tous et Bonnes fetes de fin d'annee!

Nouvelle annee, nouvelle installation de PMB, maintenant je souhaiterais savoir comment proceder pour:

1. scanner avec un lecteur de code barre les Livres presents dans la bibliotheque de mon ecole
2. recuperer automatiquement les informations  sur les livres par l'intermediare de l'ISBN
3. Editer mes propres codes barre a imprimer pour organiser ma bibliotheque en suivant le Dewey Decimal System

Merci pour votre aide!

Réponses

  • Re-Bonjour,

    Probleme #1, regle, mon lecteur de code barre est reconnu, rest maintenant pb #2 et #3...quelquesoit le serveur z39.50 sur lequel j'effectue mes rechereches, pmb reste bloque sur "wait...trying to connect to server"...
  • Bonjour,
    pour que les serveurs z39.50 fonctionnent, l'extension php yaz doit être activée sur le serveur.
    Pour les étiquettes, il y en a deux formes : les étiquettes de codes-barres sont créées dans Editions\code-barres\génération libre (https://doc.sigb.net/pmb42/co/edit_cbgen_libre_v42.html).
    Pour les étiquettes de cote comportant la cote Dewey, il faut ajouter les exemplaires à un panier, ensuite dans Catalogue\paniers\actions choisir Etiquettes de cote. Il y a la possibilité de pré-paramétrer le format des feuilles d'étiquettes dans Editions\Etiquettes\modèles de planches. Afin que la cote de l'exemplaire soit pré-remplie, la cote Dewey devra avoir été saisie dans la notice du document, dans Indexation décimale.


  • Attention, l'indexation décimale pré rempli effectivement le champ cote de l'exemplaire avec l'indice, mais n'ajoute pas les trois lettres
  • Mes exemplaires sont intégralement pré-cotés (indexation + 3 premières lettres de l'auteur). Par contre, je n'arrive pas à trouver comment j'ai paramétré cela... :(
  • Hello,
    pas sûre à 100% mais ce n'est pas le paramètre : prefill_cote ? (administration>outils>paramètres>paramètre généraux


  • Bonjour,
    j'ai bien activé ce paramètre, je suis sûr qu'il complète la cote par l'indexation décimale mais j'ai un doute pour les premières lettres de l'auteur, il faudrait que j'aille jeter un coup d’œil au script utilisé.
  • Bonjour a tous,

    J'ai bien active l'extension yaz dans mon php.ini,  copie les fichiers .dll dans /php/ et /php/ext/, relance le serveur, yaz n'apparait toujours pas dans mon php.info....est ce du au fait que je soit en php 7.3 ?
  • Bonjour,
    yaz pour php 7.3 est en développement mais la version pour php 7.2 fonctionne (selon un autre fil de discussion du forum). Voici le lien pour le récupérer : http://ftp.indexdata.dk/pub/phpyaz/

  • 10 janv. modifié
    Bonjour,
    J'ai bien la version 5.25 de yaz, est elle incompatible avec php 7.3? dois je downgrader mon serveur?
    Voici le message que j'ai au demarrage d'Apache


  • Bonjour,
    surtout pas, il faut rester en php 7.3. Il faut cette version de yaz http://ftp.indexdata.dk/pub/phpyaz/windows/php-7.2-x86-thread-safe/. Pour les endroits où copier les différents fichiers, mon tuto pour MAMP peut éventuellement vous aider https://pmbnormandie.wordpress.com/2017/05/11/activer-la-recherche-z39-50-sous-mamp/


  • Bonjour,
    Merci de votre aide, j'ai suivi a la lettre les indications de votre tuto, et reinstalle les fichiers yaz telecharges sur le lien inclu, on progresse! plus de message d'erreur au demarrage d'Apache, mais toujours bloque sur "Trying to connevct to server" lors d'une recherche z39.5.
    De plus, Yaz n'apparait toujours pas comme module dans mon php.info.....
  • Vous avez bien supprimer tous les fichiers de yaz 5.25 ? Si ce n'est pas le cas, cela peut générer des conflits. Je n'ai pas testé yaz pour php 7.2 avec php 7.3 mais il semblerait que cela fonctionne pourtant. Le problème qui pourrait se présenter, c'est qu'il faut éventuellement ouvrir un port sortant pour yaz si vous êtes en réseau.
  • J'ai bien supprime tous les anciens fichiers ya 5.25, redemarre Xampp et windows, toujours rien...
    Je teste actuellement PMB sur mon portable avec xampp installe en local.
    Ou dois je ouvrir un port pour yaz?
    Pourquoi yav n'apparait-il pas dans mon php.info?
    PS: Envore merci pour votre aide!
  • J'ai bien peur que cette version de yaz ne fonctionne pas avec Xamp et php 7.3.
  • Quelle configuration me conseillez vous ? versions de pmb, xampp, php, etc...?
  • Bonjour, personnellement je préconise plutôt une installation en ligne (moins contraignante) avec un coût annuel entre 50 et 100€ selon les hébergeurs. En local, un collègue utilise PMB 7.3 avec Wampserver sans souci. Jusque là je préconisais plutôt MAMP (très facile d'installation) mais il n'est pas encore sorti avec php 7.3.
    Selon moi, si l'on a impérativement besoin de z39.50, installer alors PMB 5.0.7 et mettre à jour ensuite vers PMB 7.3 avec un serveur qui utilisera la bonne version de yaz.

Connectez-vous ou Inscrivez-vous pour répondre.